close

[Solved] An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows

Hello Guys, How are you all? Hope You all Are Fine. Today I am trying to install a node on windows, But I always get this error An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows NodeJS. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows Error Occurs ?

I am trying to install node on win machine, I always get this error:

An error occurred while applying security settings.
Authenticated Users is not a valid user or group. This
could be a problem with the package, or a problem
connecting to a domain controller on the network. Check
your network connection and click Retry, or Cancel to
end the install.

How To Solve this An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows?

  1. How To Solve this An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows?

    Error is saying you have to add Authenticated Users to the localgroup. Just follow the below step to add “Authenticated Users”. To Solve this An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows We need to create Authenticated Users. So that first of all search Computer Management in your windows search.

Solution 1 : add “Authenticated Users”

Error is saying you have to add Authenticated Users to the localgroup. Just follow the below step to add “Authenticated Users”.

  • Open Your CMD as administrator.
An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows
  • Then type net localgroup /add “Authenticated Users” in your cmd.
  • Now you can retry to install your nodejs.

Solution 2 : Try the Previous Version

  1. Just download old version (v14.17.1).
  2. And try to install older version in your PC.
  3. This solution is worked me.

Solution 3 : add the missing group

We need to create Authenticated Users. So that first of all search Computer Management in your windows search.

An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows
  • Just click on the “Local Users and Group” tree. Open the “Local Users and Group” tree. Open the “Groups” folder and search for a profile named “Authenticated Users”, it should not there.
An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows
  • So we need to create Authenticated Users. Just Right-click on the Groups folder and select New Group.
An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows
  • Type in “Authenticated Users” (case sensitive) as the New Group name and select Create.
An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows
  • Now you can try to install node js.

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also Read

Please Rate Our Solution to Motivate Us For Give Our Best

2 thoughts on “[Solved] An error occurred while applying security settings. Authenticated Users is not a valid user or group in nodejs windows”

  1. “Solution” #1 is basically the same as “Solution” #3. They add unnecessary user groups to the system. The users following these “solutions” (which are just bad workarounds at best) are basically just polluting their systems with a user group that probably will never ever again be needed.

    And now that Node.js 12.22.3, 14.17.3, 16.4.2 are out and contain the fix for the problem, you can just download these versions from the official site: https://nodejs.org/en/

    Reply

Leave a Comment