close

[Solved] laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0

Hello Guys, How are you all? Hope You all Are Fine. Today I am trying to install laravel/ui with composer And I am using this command composer require laravel/ui But, I am facing following error laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 in PHP. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How This Error Occurs ?

I am trying to install laravel/ui with composer And I am using this command.

composer require laravel/ui

But, I am facing following error.

laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 -> found illuminate/console[v8.0.0, …, 8.x-dev] but these were not loaded, likely because it conflicts with another require. – Root composer.json requires laravel/ui ^3.2 -> satisfiable by laravel/ui[v3.2.0, 3.x-dev]. and here is my composer.json:

How To Solve laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 Error ?

  1. How To Solve laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 Error ?

    To Solve laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 Error Just Use This Command: composer require laravel/ui:^2.4 Instead of this command: composer require laravel/ui Now, your error should be solved. Second solution is If solution 1 not worked then Just try this command to install laravel/ui 1.2: composer require laravel/ui “^1.2” now your error must be solved.

  2. laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0

    To Solve laravel/ui[v3.2.0, …, 3.x-dev] require illuminate/console ^8.0 Error Just Use This Command: composer require laravel/ui:^2.4 Instead of this command: composer require laravel/ui Now, your error should be solved. Second solution is If solution 1 not worked then Just try this command to install laravel/ui 1.2: composer require laravel/ui “^1.2” now your error must be solved.

Solution 1: Use laravel/ui 2.4

Just Use This Command.

composer require laravel/ui:^2.4

Instead of this command.

composer require laravel/ui

Now, your error should be solved.

Solution 2: Use laravel/ui 1.2

If solution 1 not worked then Just try this command to install laravel/ui 1.2

composer require laravel/ui "^1.2"

Solution 3: Use this command

First of all run this all 4 commands one by one.

composer update
composer clearcache 
composer selfupdate
composer dumpautoload

Then Run This command to install Laravel UI.

composer require laravel/ui

Hope this worked for You.

Summary

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also, Read

Please Rate Our Solution to Motivate Us For Give Our Best

Leave a Comment