close

[Solved] Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel

Hello Guys, How are you all? Hope You all Are Fine. Today I am trying to run composer install but i am facing folllowing error Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement in laravel. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement Error Occurs ?

How To Solve Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement Error ?

  1. How To Solve Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement Error ?

    To Solve Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement Error This error occurs because of php version defined in your composer.json file that you have something like below. Just Update this requirement to php: “^7.3|^8.0” something like this. Second solution is If you are using composer install and you are facing this error then you just have to run composer install command with ignoring platform requirements here is command Just run this command.

  2. Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement

    To Solve Root composer.json requires php ^7.3 but your php version (8.0.0) does not satisfy that requirement Error This error occurs because of php version defined in your composer.json file that you have something like below. Just Update this requirement to php: “^7.3|^8.0” something like this. Second solution is If you are using composer install and you are facing this error then you just have to run composer install command with ignoring platform requirements here is command Just run this command.

Solution 1: update php requirement in composer.json

This error occurs because of php version defined in your composer.json file that you have something like below.

"require": {
    "php": ">=7.3",
},

Just Update this requirement to php: “^7.3|^8.0” something like this.

"require": {
    "php": "^7.3|^8.0",
},

Solution 2: Use this command

If you are using composer install and you are facing this error then you just have to run composer install command with ignoring platform requirements here is command Just run this command.

composer install --ignore-platform-reqs

Summary

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also, Read

Please Rate Our Solution to Motivate Us For Give Our Best

Leave a Comment