close

[Solved] Using / for division is deprecated and will be removed in Dart Sass 2.0.0 in Nuxtjs

Hello Guys, How are you all? Hope You all Are Fine. Today In Nuxtjs using vuetify throwing lots of error Using / for division is deprecated and will be removed in Dart Sass 2.0.0. during yarn dev in Nuxtjs. So Here I am Explain to you all the possible solutions here.

Without Wasting your time, Lets start This Article to Solve This Error.

How Using / for division is deprecated and will be removed in Dart Sass 2.0.0 Error Occurs ?

Today In Nuxtjs using vuetify throwing lots of error Using / for division is deprecated and will be removed in Dart Sass 2.0.0. during yarn dev in Nuxtjs

How To Solve Using / for division is deprecated and will be removed in Dart Sass 2.0.0 Error ?

Question: How To Solve Using / for division is deprecated and will be removed in Dart Sass 2.0.0 Error?
Answer: To solve this issue Just Change your sass version to use the tilde ~ and it should work. This is because it will prohibit updated minor versions from being used, and allow only patches. Example package.json line is “sass”: “~1.32.6”

Solution 1

The tilde ~ has been the default semver range specifier for package.json dependency definitions for two and a half years. Thanks to npm install --save, package authors have been pinning to versions within a fixed major and minor pair but a floating patch version.

Change your sass version to use the tilde ~ and it should work. This is because it will prohibit updated minor versions from being used, and allow only patches.

Example package.json line:

"sass": "~1.32.6"

Solution 2

I Think There’s an issue with vuetify I think. But if you use yarn, you can use

  "resolutions": {
    "@nuxtjs/vuetify/**/sass": "1.32.12"
  }

in package.json.

Solution 3

If you use npm, you can just simply add

"devDependencies": {
    ...,
    "sass": "~1.32.12"
}

to package.json

Solution 4

Just Follow below Steps.

  1. Remove node_modules rm -r .\node_modules\
  2. remove package-lock.json rm -r .\package-lock.json
  3. Add one line "sass": "1.32.13" into package.json under devDependencies section.

Solution 5

Don’t use version 1.33.0, use the version before that 1.32.13 for now. Change it on your package.json "sass": "1.32.13" And wait for the fix on the next version.

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also Read

Leave a Comment