close

[Solved] WARNING: Value for scheme.platlib does not match. Please report this

Hello Guys How are you all? Hope you all are fine. Today When I am trying to upgrade pip or install any packages I get a series of warnings in Python: WARNING: Value for scheme.platlib does not match. Please report this. So Here I am Explain to you all the possible solutions Here.

Without Wasting your time, Lets start This Article to Solve This Error in Anaconda.

How WARNING: Value for scheme.platlib does not match. Please report this Error Occurs?

I Am Trying to install Packages And I just notice that when I try to upgrade pip or install any packages I get a series of warnings:

milanPatel ~ $python3 -m pip install --upgrade pip
WARNING: Value for scheme.platlib does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/lib/python3.9/site-packages
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages
WARNING: Value for scheme.purelib does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/lib/python3.9/site-packages
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages
WARNING: Value for scheme.headers does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/include/python3.9/UNKNOWN
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/include/python3.9
WARNING: Value for scheme.scripts does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/bin
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/bin
WARNING: Value for scheme.data does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9
WARNING: Additional context:
user = False
home = None
root = None
prefix = None
Requirement already satisfied: pip in /opt/homebrew/lib/python3.9/site-packages (21.1)
WARNING: Value for scheme.platlib does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/lib/python3.9/site-packages
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages
WARNING: Value for scheme.purelib does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/lib/python3.9/site-packages
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/lib/python3.9/site-packages
WARNING: Value for scheme.headers does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/include/python3.9/UNKNOWN
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/include/python3.9
WARNING: Value for scheme.scripts does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew/bin
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9/bin
WARNING: Value for scheme.data does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /opt/homebrew
sysconfig: /opt/homebrew/opt/[email protected]/Frameworks/Python.framework/Versions/3.9
WARNING: Additional context:

How to Solve WARNING: Value for scheme.platlib does not match. Please report this Error?

Solutions

Qusetion: How WARNING: Value for scheme.platlib does not match. Please report this Error Occurs?
Answer: Just Downgrading to an earlier version of pip fixed it for me. Just Downgrade your version. try this command to downgrade the pip version. python -m pip install pip==21.0.1

Solution 1

Just Downgrading to an earlier version of pip fixed it for me. Just Downgrade your version. try this command to downgrade the pip version. python -m pip install pip==21.0.1

Try Out This Command to Solve This Error

python -m pip install pip==21.0.1

Solution 2

According to the pip v2.1 changelog, this message/error is intentional. See the first paragraph of the changelog.

 ~  pip install numpy                                   
WARNING: Value for scheme.headers does not match. Please report this to <https://github.com/pypa/pip/issues/9617>
distutils: /Users/me/.pyenv/versions/3.9.4/include/python3.9/UNKNOWN
sysconfig: /Users/me/.pyenv/versions/3.9.4/include/python3.9
Successfully installed numpy-1.20.2

Rolling back one version as suggested in Solution 1 fixed the issue.

Solution 3

As Per pip Maintainer said

For those who want a quick answer to silencing this warning: python -m pip install pip==21.0.1 — you can pin to an older version of pip for now.

I don’t think that’s necessary since this warning is not harmful per-se, and doesn’t affect any installation logic.

Solution 4

pip itself is just a normal python package. Thus you can install pip with pip. Of cource, you don’t want to affect the system’s pip, install it inside a virtualenv.

Follow Below Step To downgrade pip version to solve WARNING: Value for scheme.platlib does not match. Please report this this warning message.

  • Step 1: Open Your Terminal.
  • Step 2: Downgrade your PIP to lower Version 21.0.1.
  • Step 3: Run Below Command in your Terminal
  • Step 4: python -m pip install pip==21.0.1
  • Thats It. Your Warning Message now gone.

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also Read

Please Rate Our Solution to Motivate Us For Give Our Best

Leave a Comment