close

[Solved] This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead

Hello Guys, How are you all? Hope You all Are Fine. Today I am facing following error This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead in Angular. So Here I am Explain to you all the possible solutions here.

Without wasting your time, Let’s start This Article to Solve This Error.

How This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead Error Occurs ?

I am facing following error.

This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead

How To Solve This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead Error ?

  1. How To Solve This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead Error ?

    To Solve This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead Error Here You just need to change angular-devkit/build-angular version from ^13.0.2 to ^12.2.8 and Now your problem must be solved. Second solution Just need to change @angular-devkit/build-angular in Package.json. Just open Your package.json file and find this line: “@angular-devkit/build-angular”: “^13.0.2” replace above line with this Line: “@angular-devkit/build-angular”: “~0.1102.3” Now, Run Your app and Your error must be solved.

  2. This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead

    To Solve This version of CLI is only compatible with Angular versions ^13.0.0, but Angular version 12.2.13 was found instead Error Here You just need to change angular-devkit/build-angular version from ^13.0.2 to ^12.2.8 and Now your problem must be solved. Second solution Just need to change @angular-devkit/build-angular in Package.json. Just open Your package.json file and find this line: “@angular-devkit/build-angular”: “^13.0.2” replace above line with this Line: “@angular-devkit/build-angular”: “~0.1102.3” Now, Run Your app and Your error must be solved.

Solution 1: Change build-angular

Here You just need to change angular-devkit/build-angular version from ^13.0.2 to ^12.2.8 and Now your problem must be solved.

Solution 2: run This command

Open Your terminal And just run this command.

npm i @angular-devkit/[email protected] --force
npm i @angular/[email protected]

Now, Your error should be solved.

Solution 3: Change @angular-devkit/build-angular in Package.json

Just need to change @angular-devkit/build-angular in Package.json. Just open Your package.json file and find this line.

"@angular-devkit/build-angular": "^13.0.2"

replace above line with this Line.

"@angular-devkit/build-angular": "~0.1102.3"

Now, Run Your app and Your error must be solved.

Summary

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also, Read

Please Rate Our Solution to Motivate Us For Give Our Best

Leave a Comment