close

[solved] You have missing dependencies! # Mandatory: spyder_kernels >=2.0.1,<2.1.0 : 2.0.1 (NOK)

Hello Guys How are you all? Hope you all are fine. Today spyder gives me an error message like above, but I cannot solve it. it gives me Spyder 5 missing dependencies – spyder_kernels version error after just updating spyder. So Here I am Explain to you all the possible solutions Here.

Without Wasting your time, Lets start This Article to Solve This Error in Anaconda.

How You have missing dependencies! # Mandatory: spyder_kernels >=2.0.1,<2.1.0 : 2.0.1 (NOK) error Occurs?

Spyder gives me error message like above, but I cannot solve it.

You have missing dependencies!

# Mandatory :
spyder kernels
 >= 2.0.1,<2.1.0 : 2.0.1 (NOK)

Please install them to avoid this message.
Note: Spyder could work without some of these dependencies, however to
have a smooth experience when using Spyder we strong/yrecommend you
to install all the listed missing dependencies.

Failing to install these dependencies might result in bugs. Please be sure that
any found bugs are not the direct result of missing dependencies, prior to
reporting a new issue.

How to Solve You have missing dependencies! # Mandatory: spyder_kernels >=2.0.1,<2.1.0 : 2.0.1 (NOK) ?

Question: How to Solve You have missing dependencies! # Mandatory: spyder_kernels >=2.0.1,<2.1.0 : 2.0.1 (NOK) ?
Answer:
 That error message is caused by a bug in Spyder and it’ll be fixed in our next version (5.0.1), to be released shortly. You can safely ignore it for now because it incorrectly reports that the right version of spyder-kernels is missing, when it’s actually installed.

Solutions

  1. That error message is caused by a bug in Spyder and it’ll be fixed in our next version (5.0.1).
  2. To be released shortly.
  3. You can safely ignore it for now.
  4. It incorrectly reports that the right version of spyder-kernels is missing.
  5. When it’s actually installed.

So For Now a Days Temporary Solution Is Just To Ignore This Error. We are keep finding Solution for this error So we will update here.

Solution 2

The message says “you’ve installed spyder_kernels 2.0.1, but I need a version lower than (<) 2.0.1″, doesn’t it?
spyder package in official repo seems a little bit older than latest (4.2.1).

Summery

It’s all About this issue. Hope all solution helped you a lot. Comment below Your thoughts and your queries. Also, Comment below which solution worked for you?

Also Read

Please Rate Our Solution to Motivate Us For Give Our Best

Leave a Comment